1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, If you'd like to instant message with many other users, then join our
    Official Rune-Status Discord Server!
    Dismiss Notice
  3. Got your own Server? Looking for a Server to play right now??
    Make sure you check out the Public Server Directory!
    Dismiss Notice
  4. If you're new to the Rsps Scene and want to jump straight into learning how to Set-up and Customise your own RuneScape Private Sever then check out the Guides and Tutorials for RS2 here.
    Dismiss Notice
Dismiss Notice
Hey Guest,
Are you sure your posting in the Right Sections?
If your unsure which RuneTek version you are working with visit this page to find out.

OSRS OSRS 317 / 160 hybrid packing issue

Discussion in 'Help & Requests' started by Valiant, Jan 16, 2018.

  1. Hi i've followed Ians guides on how to retrieve, dump and pack data into a 317 client. However im having issues with actually displaying this data. With maps i can just teleport to the co-ords which work fine. But for Items and Npcs ?? how do i actually spawn them in without them 1) Do nothing on the command. 2) appear nulled in your inventory ?

    Im using Elvarg release from r-s if that helps.
     
  2. You also have to update your definition files. In your server folder there should be some files called npcdefinitions, itemdefinitions etc.. Your cache contains data about the models, options and other data for those npc's and items but not everything. To complete all the data that you need your server uses those definition files which are often dumped from wiki/cache (some definition files also contain the same info as in the cache). To make your items/npc's work you have to update those definition files.

    For spawns, their should also be a server sided file that determines the spawn locations of all your npcs. If you want to spawn an npc just put the spawnlocation of that npc in that file.
     
    • Informative Informative x 1
    • List
  3. i have added up to opcode 149 in my itemDefinition client side. It's weird because it worked on another server (Exotic) but Elvarg for some reason is displaying them as null items, which makes me think it is something server side, but even when i manually add the definitions of the item in my item.json file (server side) it still appears null. There is no other readValues or opcodes server side to copy either, i don't know what im missing.. Especially since it worked on another server.
     
Loading...